Open SidemenuDocs
Docs
Close Sidemenu

Deprecating Support for TLS 1.0 and TLS 1.1deprecating-support-for-tls-1-0-and-tls-1-1

Note Type Info

As of June 1st, 2021 Telnyx will be deprecating the support of TLS 1.0 and TLS 1.1. Any application that interfaces with Telnyx will need to use TLS 1.2 or newer to continue to operate properly. 

What is TLS?what-is-tls-

Transport Layer Security (TLS) provides protections to allow client and server applications to communicate over an open communication channel, such as the Internet. Over the course of 25 years, there have been four major versions of TLS that address security vulnerabilities or exploitations in each release.

TLS 1.0Telnyx Developers
TLS 1.1Telnyx Developers
TLS 1.2Telnyx Developers
TLS 1.3Telnyx Developers

TLS Support at Telnyxtls-support-at-telnyx

Telnyx currently supports all major releases of TLS. This allows for wide compatibility and provides an easier entry into connecting with Telnyx. As Telnyx has grown this broad support is no longer in line with our goal to ensure a safe and secure platform for our customers.

In light of this, Telnyx will no longer support TLS 1.0 and TLS 1.1 after June 1st, 2021

Ensuring Continued Support for Your Communicationsensuring-continued-support-for-your-communications

Before June 1st, 2021 you may need to take action to ensure that your applications continue to work without interruption. Once this change takes effect, all connections to Telnyx that use the protocols TLS 1.0 and TLS 1.1 will no longer work.

This may include SIP Connections that use IP Address or FQDN authentication, as well as Telnyx API applications which interface with any of the following domains:

  • sip.telnyx.com (also includes .com.au, .eu and .ca)
  • api.telnyx.com
  • sms.telnyx.com
  • data.telnyx.com
  • lrnlookup.telnyx.com
  • Any other public *.telnyx.com domain.

If you are unsure if you are using TLS 1.0 or TLS 1.1 then you can follow the instructions below to check your configuration. Otherwise, if you are using TLS 1.2 or greater, you do not need to take any action.

Updating Your Application to Use A Supported Version of TLSupdating-your-application-to-use-a-supported-version-of-tls

TLS 1.2 was released in 2008, so the vast majority of software libraries and clients released after 2008 already support this protocol.


Updating your Telnyx API application to use a supported TLS version

If your application makes requests to the Telnyx API over HTTP, ensure that the HTTP library you use is updated to the latest version and uses TLS 1.2 or greater.


Updating your Telnyx SIP Connection to use a supported TLS version

If you have Telnyx SIP Connections set up to use SIP over TLS, ensure that your SIP client or device supports TLS 1.2 or greater, or update your client to a version which supports TLS 1.2 or greater. For assistance in configuring SIP clients for use with Telnyx, read our configuration guides.

Frequently Asked Questions about TLS Deprecationfrequently-asked-questions-about-tls-deprecation

Once I have confirmed we are not using TLS 1.0 or TLS 1.1, is there anything else I need to do?

No other actions are needed once you are using TLS 1.2 or newer.


I am unable to update my application by the specified date, what will happen?

If your application continues to use TLS 1.0 or TLS 1.1 after June 1st 2021, then it will no longer work. Feel free to reach out to support by logging into your Mission Control Portal accountTelnyx Developers and using the chat popup in the lower right corner for more assistance.


How are other Telnyx developers preparing for this change?

The Telnyx Developer Slack community lets you connect with your fellow Telnyx developers and our API support engineers. To chat to other Telnyx developers about this upcoming change, join the community at joinslack.telnyx.comTelnyx Developers.


Can I update to TLS 1.2 now?

Yes! We currently have full support for TLS 1.2 and greater. Simply follow the steps outlined above to update your application.


Why is Telnyx deprecating support of TLS 1.0 and TLS 1.1?

The greater technical community has identified TLS 1.0 and TLS 1.1 to no longer meet modern standards for encryption and privacy. As we aim to provide the best level of protection to all our customers, we can no longer support these outdated encryption protocols.

Was this page helpful?