This is the current API V1 documentation. Explore our API V2 if you’d like to test new features.

Open SidemenuDocs
Docs
Close Sidemenu
Choose:
Python
Python

Development Prerequisitesdevelopment-prerequisites

Follow the steps below to use Python to interact with the Telnyx API and get started with the Telnyx Python guides.

  1. 1Go through the relevent Telnyx Setup Guide to setup your Portal for use.
  1. 2You'll need to ensure that you have Python installed on your computer. If Python isn’t installed, follow the official installation instructionsTelnyx Developers for your operating system to install it. You can check this by running the following:
python --version
  1. 3You’ll need to have pip installed. If pip isn’t installed, follow the official pip installation instructionsTelnyx Developers for your operating system to install it. You can check this by running:
pip --version
  1. 4Install the required Python dependencies (Requests) by running the following:
pip install requests